2025年12月18日 18時24分頃、iPad端末においてユーザーポータルからクライアント証明書のインポートが正常に実施されない事象を確認しました。
現在は解消しているため、以下に本事象の詳細をご案内します。
概要
iPad端末でユーザーポータルからクライアント証明書のインポートを実施した際に、「.app」形式のアプリがダウンロードされる事象が発生しました。
原因
2025年12月15日のリリースより、macOS向けクライアント証明書インポートアプリの提供を開始しました。
上記に伴い、macOS端末でユーザーポータルからクライアント証明書をインポートする際に、「.app」形式のインポートアプリがダウンロードされる仕様になっております。
当該機能の実装時に、macOSとiPadOSの判別処理が適切に行われていなかったため、ユーザーポータルのメニューからクライアント証明書をインポートする際に、iPad端末であっても「.app」形式のインポートアプリのリンクが表示され、ダウンロードを求められる状態となっていました。
iPadOSでは該当のアプリに対応していないため、結果としてクライアント証明書のインポートが正常に完了しない事象が発生しました。
対処
2025年12月22日 18時41分に、クライアント証明書のダウンロードを実施する際にmacOSとiPadOSを判別する処理を追加し、本事象を解消しました。